#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b(instagram|ig)\s*[:-]\s*\K([\w.]+)\b"
Local $sString = "instagram - myigusername93" & @CRLF & _
"ig: myigusername93"
Local $sSubst = "<a href="$1">$1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)