$re = '/^(?:(?:http|https)://)?((?:[A-ZА-ЯЁ0-9](?:[A-ZА-ЯЁ0-9-]{0,61}[A-ZА-ЯЁ0-9])?\.)+(?:[A-ZА-ЯЁ]{2,6}\.?|[A-ZА-ЯЁ0-9-]{2,}(?<!-)\.?))(?:/?|[/?]\S+)$/iu';
$str = 'http://q.we.r.t.y.y.trytry.www.ёёёёё.йё/ывёа/фыёвыфвыв/?ывавёыа&фыыёва
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);