package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:(?:[[:xdigit:]]{4}\.){2}[[:xdigit:]]{4}|(?:[[:xdigit:]]{2}[:-]){5}[[:xdigit:]]{2}|[[:xdigit:]]{12})$`)
var str = `1234567890abcd
12:34:56:78:90:12
12-34-56-78-90-12
1234.5678.9012
123456789012
12:34:56:78:90:12:34`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}