use strict;
my $str = '1234567890abcd
12:34:56:78:90:12
12-34-56-78-90-12
1234.5678.9012
123456789012
12:34:56:78:90:12:34';
my $regex = qr/^(?:(?:[[:xdigit:]]{4}\.){2}[[:xdigit:]]{4}|(?:[[:xdigit:]]{2}[:-]){5}[[:xdigit:]]{2}|[[:xdigit:]]{12})$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}