using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<!--((?:(?!-->).)*)-->((?:(?!<!--)[\s\S])+)<!--((?:(?!-->).)*)-->";
string substitution = @"";
string input = @"<!-- Text --><b>Text</b>
<a href=""google.com"">Link</a>
<div class=""col""><h1>Nested Content</h1><p>More content</p>
</div>
<!-- END of Text -->";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}