const regex = new RegExp('<!--((?:(?!-->).)*)-->((?:(?!<!--)[\\s\\S])+)<!--((?:(?!-->).)*)-->', 'gmi')
const str = `<!-- Text --><b>Text</b>
<a href="google.com">Link</a>
<div class="col"><h1>Nested Content</h1><p>More content</p>
</div>
<!-- END of Text -->`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);