use strict;
my $str = 'May 1 2014 12:10:10:000AM';
my $regex = qr/^[\w]{3} {1,2}[\d]{1,2} [\d]{4} ([\d]{2}:){3}[\d]{3}(AM|PM)$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}