import Foundation
let pattern = #"@\[([^\]\s]+)([^\]]+)\]\([^\)]+\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Hello @[Kenneth Auchenberg](user:1) its been long. Tell @[Pete Lacey](user:6) I will see him tomorrow"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[$1$2](site.com/user/$1)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)