using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\([^\)]*(?=\.\w+$)";
string input = @"02 Back for Good (Radio Mix).mp3
02 Back for Good (Radio Mix.mp3";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}