package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(… )|( \[-\])`)
var str = `"Massage, Rückenmassage, Heilmassage, Wellness Massage, Fußmassage, Fußreflexzonenmassage, Heilpraktiker,… Berlin, Osteopathie, Manuelle Lymphdrainage, Charlottenburg, Ohrakupunktur, Medizinische Massage, Spannungskopfschmerz, Heilpraktiker Akupunktur, Firmenmassage, Behandlung von Rückenbeschwerden, Tiefengewebemassage, Schlüsselzonenmassage nach Dr. Marnitz, Behandlung von Spannungskopfschmerzen, Massage-Praxen, Staatlich Geprüfte Masseure, Heilpraktiker für Ohrakupunktur, Atembehandlung nach Middendorf, Schlüsselzonenmassagen nach Dr. Marnitz Berlin, Osteopathie, Manuelle Lymphdrainage, Charlottenburg, Ohrakupunktur, Medizinische Massage, Spannungskopfschmerz, Heilpraktiker Akupunktur, Firmenmassage, Behandlung von Rückenbeschwerden, Tiefengewebemassage, Schlüsselzonenmassage nach Dr. Marnitz, Behandlung von Spannungskopfschmerzen, Massage-Praxen, Staatlich Geprüfte Masseure, Heilpraktiker für Ohrakupunktur, Atembehandlung nach Middendorf, Schlüsselzonenmassagen nach Dr. Marnitzweniger [-]"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}