# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|;)(([^;]{1,10})([^;]*))/$3/igm;t' <<< "firstField;secondField;thirdField;fourth very long field which I need to truncate;fifth very long field which I need to truncate"