#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)(^|;)(([^;]{1,10})([^;]*))"
Local $sString = "firstField;secondField;thirdField;fourth very long field which I need to truncate;fifth very long field which I need to truncate"
Local $sSubst = "$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)