$re = '/(^|;)(([^;]{1,10})([^;]*))/im';
$str = 'firstField;secondField;thirdField;fourth very long field which I need to truncate;fifth very long field which I need to truncate';
$subst = "$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;