re = /(^|;)(([^;]{1,10})([^;]*))/im
str = 'firstField;secondField;thirdField;fourth very long field which I need to truncate;fifth very long field which I need to truncate'
subst = '$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result