import Foundation
let pattern = #"(^|;)(([^;]{1,10})([^;]*))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"firstField;secondField;thirdField;fourth very long field which I need to truncate;fifth very long field which I need to truncate"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)