package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\.]*[\d][\s\d]*[\.]*[\d]+)\s([A-Z]{3})`)
var str = `любое Ñлово: 5.00 RUR;
любое Ñлово: 500 125.00 RUR;
любое Ñлово: .00 RUR;
любое Ñлово: 0.00 RUR;
любое Ñлово: 123 500 125.00 RUR;
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}