#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^LOG:(?:[^,]*,){4}\K(?!0+,)([^,]*)"
Local $sString = "LOG:69369,1,30,40,80,06,1" & @CRLF & _
"LOG:69369,1,30,40,C0,06,1" & @CRLF & _
"POS:69453,69576034,-19244227,1,0" & @CRLF & _
"LOG:69405,2,30,40,00,06,2" & @CRLF & _
"POS:69333,69576024,-19244235,1,0" & @CRLF & _
"LOG:69405,2,30,40,C0,06,2 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")