using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+(?:(?: \d+)*\/\d+)?)$";
string input = @"1
200
1/2
3/8
1 1/2
200 3/8
NOT
number
5%
1 1/2 4
1 1/2 1/2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}