$re = '/1str|2str|3str/';
$str = '123 2str 3str 1str';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);