re = /\b ?([A-Za-z-]+) ?\b/
str = '"Right now!" she shouted, and hands fluttered in the air - amid a few cheers - for about two minutes.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end