package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(:.+)(?(1)Cool!)`)
var str = `# match String Cool! only if there is a : somewhere preciding it
Ein String: mit einem Zeichen drin Cool!
Ein String ohne Zeichen drin Cool!`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}