#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(((\d{1,3})\.)(\d){1,3}|((\d{3}(\,))*)(\d{1,3})(\.\d{1,3})*)$"
Local $sString = "3.5" & @CRLF & _
"30.50" & @CRLF & _
"3,500" & @CRLF & _
"3,500.555" & @CRLF & _
"300,500.555" & @CRLF & _
"0.5" & @CRLF & _
"0,5" & @CRLF & _
"00,5" & @CRLF & _
"" & @CRLF & _
"300,000,500.555" & @CRLF & _
"" & @CRLF & _
"300,000,500" & @CRLF & _
"" & @CRLF & _
"1,000,005.5" & @CRLF & _
"12,5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")