using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(((\d{1,3})\.)(\d){1,3}|((\d{3}(\,))*)(\d{1,3})(\.\d{1,3})*)$";
string input = @"3.5
30.50
3,500
3,500.555
300,500.555
0.5
0,5
00,5
300,000,500.555
300,000,500
1,000,005.5
12,5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}