# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(((\d{1,3})\.)(\d){1,3}|((\d{3}(\,))*)(\d{1,3})(\.\d{1,3})*)$"
test_str = ("3.5\n"
"30.50\n"
"3,500\n"
"3,500.555\n"
"300,500.555\n"
"0.5\n"
"0,5\n"
"00,5\n\n"
"300,000,500.555\n\n"
"300,000,500\n\n"
"1,000,005.5\n"
"12,5")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.