// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(((\d{1,3})\.)(\d){1,3}|((\d{3}(\,))*)(\d{1,3})(\.\d{1,3})*)$").unwrap();
let string = "3.5
30.50
3,500
3,500.555
300,500.555
0.5
0,5
00,5
300,000,500.555
300,000,500
1,000,005.5
12,5";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}