import Foundation
let pattern = #"^(((\d{1,3})\.)(\d){1,3}|((\d{3}(\,))*)(\d{1,3})(\.\d{1,3})*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
3.5
30.50
3,500
3,500.555
300,500.555
0.5
0,5
00,5
300,000,500.555
300,000,500
1,000,005.5
12,5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)