$re = '/\b(?:https?:\/\/)?[^\/:]+\/.*?checkout\/b\?bag=?([A-Za-z0-9]*)$/';
$str = 'https://jasongarnerppf3f6.volusionplatformdev.com/checkout/b?bag=5ab1235aebd29702dc547df7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);