Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
^[^:\n]+(?=:.+)
"
gm
Input 1
1
New
func factorial{num if{num==1 ret{1} } ret{num*factorial{num-1}} } p:style="color: Red;"{factorial{fromVars{"target"}}}