package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\s]?_[^\s]*|\s?([^_\s]*)\s+?`)
var str = `private string __$id0 = "lala"
__$id0 = "lala"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}