import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((sdf|xvd)[a-x][0-9]{0,1})\\s+[^\\s]+\\s+[^\\s+]\\s+([^\\s]+)\\s+[^\\s]+\\s+[^\\s]+\\s+([^\\n]*)$";
final String string = "NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT\n"
+ "xvdf 202:80 0 100G 0 disk /mnt/data\n"
+ "xvda1 202:1 0 8G 0 disk /";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.DOTALL | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}