#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Showing\s+(?:\d+\s+of\s+)?([\d,.]+)\s+\(search"
Local $sString = "<div class="center">Showing 25 of 2,343,098 (search took 1.245 seconds)</div>" & @CRLF & _
"<div class="center">Showing 2343098 (search took 1.245 seconds)</div>" & @CRLF & _
"<div class="center">" & @CRLF & _
"" & @CRLF & _
" Showing 125 " & @CRLF & _
"" & @CRLF & _
" of 2,343,098 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"(search took 1.245 seconds)</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")