import Foundation
let pattern = #"Showing\s+(?:\d+\s+of\s+)?([\d,.]+)\s+\(search"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div class="center">Showing 25 of 2,343,098 (search took 1.245 seconds)</div>
<div class="center">Showing 2343098 (search took 1.245 seconds)</div>
<div class="center">
Showing 125
of 2,343,098
(search took 1.245 seconds)</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)