package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(5000(\.0)?|([0-4]?\d?\d?\d)(\.\d)?)$`)
var str = `4553.4`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}