#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([^a-zA-Z]|\b)word"
Local $sString = "word 1word !word aword"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)