re = /.*?(?=([^(]*\([^)]*")*[^)]*$)\./
str = 'Tom (Ed.) went down to the shop where the owners (J. Guys, A. Owner, and B. Ains) gathered. It was a great night.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end