using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?=(?:[^']*'[^']*')*[^']*$)";
string substitution = @"\n";
string input = @"'Field1','Field2','Field3, this field has a comma','Field4'";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}