const regex = /,(?=(?:[^']*'[^']*')*[^']*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',(?=(?:[^\']*\'[^\']*\')*[^\']*$)', 'gm')
const str = `'Field1','Field2','Field3, this field has a comma','Field4'`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);