re = /,(?=(?:[^']*'[^']*')*[^']*$)/m
str = '\'Field1\',\'Field2\',\'Field3, this field has a comma\',\'Field4\''
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result