use strict;
my $str = 'word,1.2;3.1!4.5';
my $regex = qr/(?!\.)\W/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";