#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<post author="(.*?)""
Local $sString = "<post author="luckylindyslocale" datetime="2012-03-03T04:52:00" id="p7">" & @CRLF & _
"<img src="http://img.photobucket.com/albums/v303/lucky196/siggies/ls1.png"/>" & @CRLF & _
"" & @CRLF & _
"Grams thank you, for this wonderful tag and starting this thread. I needed something to encourage me to start making some new tags." & @CRLF & _
"" & @CRLF & _
"<img src="http://img.photobucket.com/albums/v303/lucky196/holidays/stpatlucky.jpg"/>" & @CRLF & _
"Cruelty is one fashion statement we can all do without. ~Rue McClanahan" & @CRLF & _
"</post>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")