#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^₹ (([0-9]+\,[0-9]+)|([0-9]+[.]?[0-9]*(?:L|Cr)?))$"
Local $sString = "₹ 3.50L" & @CRLF & _
"₹ 3.50" & @CRLF & _
"" & @CRLF & _
"₹ 3,500" & @CRLF & _
"₹ 30000000.50Cr" & @CRLF & _
"₹ 99.50L" & @CRLF & _
"₹ 3L" & @CRLF & _
"₹ 300.50Cr" & @CRLF & _
"₹ 350Cr" & @CRLF & _
"₹ 1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"₹ 3,500L" & @CRLF & _
"₹ 3,500L" & @CRLF & _
"₹ 35,000L" & @CRLF & _
"₹ 3,500Cr" & @CRLF & _
"₹ 0,000Cr"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")