using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^₹ (([0-9]+\,[0-9]+)|([0-9]+[.]?[0-9]*(?:L|Cr)?))$";
string input = @"₹ 3.50L
₹ 3.50
₹ 3,500
₹ 30000000.50Cr
₹ 99.50L
₹ 3L
₹ 300.50Cr
₹ 350Cr
₹ 1
₹ 3,500L
₹ 3,500L
₹ 35,000L
₹ 3,500Cr
₹ 0,000Cr";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}