import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^₹ (([0-9]+\\,[0-9]+)|([0-9]+[.]?[0-9]*(?:L|Cr)?))$";
final String string = "₹ 3.50L\n"
+ "₹ 3.50\n\n"
+ "₹ 3,500\n"
+ "₹ 30000000.50Cr\n"
+ "₹ 99.50L\n"
+ "₹ 3L\n"
+ "₹ 300.50Cr\n"
+ "₹ 350Cr\n"
+ "₹ 1\n\n\n"
+ "₹ 3,500L\n"
+ "₹ 3,500L\n"
+ "₹ 35,000L\n"
+ "₹ 3,500Cr\n"
+ "₹ 0,000Cr";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}