use strict;
my $str = '₹ 3.50L
₹ 3.50
₹ 3,500
₹ 30000000.50Cr
₹ 99.50L
₹ 3L
₹ 300.50Cr
₹ 350Cr
₹ 1
₹ 3,500L
₹ 3,500L
₹ 35,000L
₹ 3,500Cr
₹ 0,000Cr';
my $regex = qr/^₹ (([0-9]+\,[0-9]+)|([0-9]+[.]?[0-9]*(?:L|Cr)?))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}