$re = '/^₹ (([0-9]+\,[0-9]+)|([0-9]+[.]?[0-9]*(?:L|Cr)?))$/m';
$str = '₹ 3.50L
₹ 3.50
₹ 3,500
₹ 30000000.50Cr
₹ 99.50L
₹ 3L
₹ 300.50Cr
₹ 350Cr
₹ 1
₹ 3,500L
₹ 3,500L
₹ 35,000L
₹ 3,500Cr
₹ 0,000Cr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);