package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$[a-zA-Z0-9\-_]+[ ]*:[ ]*[a-zA-Z0-9\-_]+`)
var str = `$colors : pippo
$colors: pippo
$colors:pippo
$colors :pippo
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}