#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?i:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d|any|tcp|udp|icmpv[46](?:[:](?:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d),(?:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d))?)(?:,(?i:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d|any|tcp|udp|icmpv[46](?:[:](?:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d),(?:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d))?))*?$"
Local $sString = "icmpV4:150,145,72"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")