import Foundation
let pattern = #"\b'\b(*SKIP)(*F)|'"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"I don't know 'how' to remove these ' things"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)