import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!^|\\n|[.!?] )[A-Z\\d][A-Za-z\\d]*(?: (?:of )?[A-Z\\d][A-Za-z\\d]*)*";
final String string = "My name is Sam Helsen or Sam H Helsen son of M Helsen working at 3M technologies as the President of Sales.\n"
+ "The first word in a sentence won't match. A capitalized word followed by \"of\" and another capitalized word will be matched: Foo of Bar. Not if the 2nd word is lowercase though: Foo of bar.\n"
+ "Words starting with digits will be matched even if not capitalized: 123foo.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}