$re = '/(.*name=".+_)\d+(_[^"]+".*)/m';
$str = 'some_data_before name="some_text_0_some_text" and then some_data after';
$subst = "$1!NEW_ID!$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;